ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ Язык Free Pascal GNU C GNU C++ Delphi Java Python 2.7 Mono C# Python 3.1 Min время, сек 0.001 0.004 0.002 0.002 0.124 0.008 0.064 0.046 Среднее время, сек 0.005 0.006 0.011 0.005 0.124 0.024 0.064 0.079 В...
ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ
Язык Free Pascal GNU C GNU C++ Delphi Java Python 2.7 Mono C# Python 3.1
Min время, сек 0.001 0.004 0.002 0.002 0.124 0.008 0.064 0.046
Среднее время, сек 0.005 0.006 0.011 0.005 0.124 0.024 0.064 0.079
Верных решений 73 5 102 9 1 2 1 301
Дано целое число, не меньшее 2. Выведите его наименьший натуральный делитель, отличный от 1.
Входные данные
Вводится целое положительное число.
Выходные данные
Выведите ответ на задачу.
Примеры
входные данные
15
выходные данные
3
Ответ(ы) на вопрос:
Гость
Паскаль:
Program P;
uses crt;
var n,i:integer;
Begin clrscr;
write(' N='); readln(n);
i:=1;
while i<=n do begin i:=i+1;
if n mod i=0 then
begin
writeln('Наименьший делитель=',i);
end;
end;
end.
Не нашли ответ?
Похожие вопросы