Помогите с Паскалем.Надо составить программу. 1)У наибольшего из чисел x,y,z найти цифру младшего разряда(единиц) и остаток от его деления на 3. 2)Написать программу,которая по номеру дня недели выдаёт количество уроков на след...

Помогите с Паскалем.Надо составить программу. 1)У наибольшего из чисел x,y,z найти цифру младшего разряда(единиц) и остаток от его деления на 3. 2)Написать программу,которая по номеру дня недели выдаёт количество уроков на следующий день.
Гость
Ответ(ы) на вопрос:
Гость
2. var n: Integer; Begin readln(n); write('Уроков '); case n of 1: writeln('6'); 2: writeln('6'); 3: writeln('6'); 4: writeln('5'); 5: writeln('5'); 6: writeln('нет'); 7: writeln('6'); end; End.
Гость
Согласно первому заданию надо сначала найти максимальный элемент uses crt; var x,y,z,max:integer; Begin writeln('Введите x y z'); readln(x,y,z); if (x>y) and (x>z) then max:=x else if (y>x) and (y>z) then max:=y else max:=z; Writeln('max =',max); Writeln('Младший разряд =',max mod 10); Writeln('Остаток от деления на 3 =',(max mod 10) mod 3); readln; end. 2) var n: Integer; Begin writeln('Введите день недели'); readln(n); write('Уроков '); case n of 1-4: writeln('6'); 5,6: writeln('5'); 7: writeln('нет'); end; End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы