Помогите с программой пожалуйста! на языке паскаль . Напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [–100; 100] и находит в каждой половине массива пару соседних элементов, сумма кото...
Помогите с программой пожалуйста! на языке паскаль . Напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [–100; 100] и находит в каждой половине массива пару соседних элементов, сумма которых максимальна .
Ответ(ы) на вопрос:
Гость
var a:array[1..20] of integer;
i,max1,ind1,max2,ind2:integer;
begin
randomize;
for i:=1 to 20 do begin
a[i]:=random(200)-100;
write(a[i]:4);
end;
writeln;
max1:=a[1]+a[2];
for i:=2 to 9 do
if a[i]+a[i+1]>max1 then
begin
max1:=a[i]+a[i+1];
ind1:=i;
end;
max2:=a[11]+a[12];
for i:=12 to 19 do
if a[i]+a[i+1]>max2 then
begin
max2:=a[i]+a[i+1];
ind2:=i;
end;
write('Сумма максимальна между ',ind1,' и ', ind1+1, ' элементом в первой половине и между ',ind2,' и ',ind2+1,' во второй половине массива');
end.
Не нашли ответ?
Похожие вопросы