Помогите с задачами по информатике через Pascal: 1. С клавиатуры вводятся целые числа, признак окончания ввода - четное число, вычислить количество двузначных, сумму - последняя цифра больше 5. Входные данные: -7, 11, 29, 115, ...

Помогите с задачами по информатике через Pascal: 1. С клавиатуры вводятся целые числа, признак окончания ввода - четное число, вычислить количество двузначных, сумму - последняя цифра больше 5. Входные данные: -7, 11, 29, 115, 28 Выходные данные: k=2, s=22 2. С клавиатуры вводят n целых чисел, посчитать произведение положительных кратных 3. Входные данные: 6, -21, 13, 7, 3, 12, -6 Выходные данные: p=36 3. С клавиатуры вводятся n целых чисел, найти среднее арифметическое положительных значений. Помогите пожалуйста, буду очень благодарна.
Гость
Ответ(ы) на вопрос:
Гость
{1} var   a,k,s: integer; begin   read(a);   k := 0; s := 0;   while a mod 2 <> 0 do     begin     if abs(a) mod 10 > 5 then       s := s + a;     a := abs(a);     if (a > 9) and (a < 100) then       k := k + 1;     read(a);     end;   writeln('k=',k,', s=',s) end. {2} var   n,i,p,a: integer; begin   read(n);   p := 1;   for i := 1 to n do     begin     read(a);     if (a > 0) and (a mod 3 = 0) then       p := p * a;     end;   writeln('p=',p) end. {3} var   n,a,i,k,s: integer; begin   read(n);   k := 0; s := 0;   for i := 1 to n do     begin     read(a);     if a > 0 then       begin       s := s + a;       k := k + 1;       end;     end;   if k = 0 then k := 1;   writeln('s=',s/k) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы