Помогите составить программу ,позволяющую найти произведение всех 3ехзначных натуральных чисел,каждое из которых при делении на 7 дает остаток 3.Ну,или подправьте ту прогу,что я составила,а то что-то у меня она неправильная.

Помогите составить программу ,позволяющую найти произведение всех 3ехзначных натуральных чисел,каждое из которых при делении на 7 дает остаток 3.Ну,или подправьте ту прогу,что я составила,а то что-то у меня она неправильная.
Гость
Ответ(ы) на вопрос:
Гость
var a,i: integer; begin a:=1; for i = 100 to 999 do begin if (i mod 3)=7 then a:=a*i; end; writeln (a); end. тип того
Гость
program morningglory; uses crt;  var y,i:integer; P:=1;  begin for i:=100 to 999 do   if i mod 7=3 then begin    P:=P*i);   end;   writeln ('Произведение чисел, дающих при делении на 7 остаток 3 =',P);  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы