Помогите составить программу с помощью цикла repeat. составить программу выводящую и суммирующую любое количество целых чисел если введено 999 о на экран выводится результат суммирования.
Помогите составить программу с помощью цикла repeat.
составить программу выводящую и суммирующую любое количество целых чисел если введено 999 о на экран выводится результат суммирования.
Ответ(ы) на вопрос:
На языке Java. Программа складывает и отрицательные и положительные числа.
class SumNum{
public static void main(String args[]){
try{
long sumNum=0,numSum=new Long(new java.io.BufferedReader(new java.io.InputStreamReader(System.in)).readLine());
do sumNum+=numSum;while((numSum>0?--numSum:++numSum)!=0);System.out.print("Результат "+sumNum);
}catch(java.io.IOException io){
System.out.println(" - Ошибка ввода!\n"); main(null);
}catch(NumberFormatException nf){
System.out.println(" - Введите целочисленное значение!\n"); main(null);
}
}
}
Не нашли ответ?
Похожие вопросы