Помогите составить программу в паскале. Дано натуральное число n. Вычислить: p=(1-1/2^2)(1-1/3^2)*...*(1-1/n^2), где n больше 2
Помогите составить программу в паскале. Дано натуральное число n. Вычислить: p=(1-1/2^2)(1-1/3^2)*...*(1-1/n^2), где n>2
Ответ(ы) на вопрос:
думаю так. var i,n:integer; p:real;
begin
cls;
write('write n '); readln(n);
for i:=2 to n do
begin
p:=p+(1-(1/sqr(i)));
end;
writeln(p);
readln;
end.
Не нашли ответ?
Похожие вопросы