Помогите составить программу!:)В массиве из 10 целых чисел заменить все отрицательные элементы на минимальный элемент, а все положительные – на максимальный.

Помогите составить программу!:)В массиве из 10 целых чисел заменить все отрицательные элементы на минимальный элемент, а все положительные – на максимальный.
Гость
Ответ(ы) на вопрос:
Гость
На паскаль:  var a: array [1..10] of integer; max, min, i: integer; begin for i := 1 to 10 do read(a[i]);  max:=-maxint;  min:= maxint; for i:= 1 to 10 do  if  (a[i]>max) then max:=a[i]; for i := 1 to 10 do if (a[i]0) then a[i]:=max; for i := 1 to 10 do write(a[i],' '); readln; readln; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы