Помогите.Информатика 9 класс.Составьте программу которая формирует массив из 16 случайных целых чисел от -20 до 20 и находит элемент с нулевым значением

Помогите.Информатика 9 класс.Составьте программу которая формирует массив из 16 случайных целых чисел от -20 до 20 и находит элемент с нулевым значением
Гость
Ответ(ы) на вопрос:
Гость
// PASCAL var   a: array [1..16] of integer;   i: integer; b: boolean; begin   randomize;   for i := 1 to 16 do a[i] := random(-20, 20);   for i := 1 to 16 do     if a[i] = 0 then begin       if b then write(', ');       write(i, '-й ');       b := true;     end;   if b then writeln('элемент(ы) равен(ны) нулю') else writeln('В массиве нету элементов, равных нулю.'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы