Помогите,плесс. на языке паскаля. напишите программу,которая в последовательности натуральных чисел определяет минимальное,оканчивающееся на 2. Программа получает числа. Признак окончания ввода 0. Количество чисел не превышает...

Помогите,плесс. на языке паскаля. напишите программу,которая в последовательности натуральных чисел определяет минимальное,оканчивающееся на 2. Программа получает числа. Признак окончания ввода 0. Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число - минимальное,оканчивающееся на 2,если таких нет,вывести на экран об этом сообщение.
Гость
Ответ(ы) на вопрос:
Гость
Var A,m:integer; Begin m:=32767; Repeat Read(A); if (A mod 10 = 2)and(A < m) then m:=A; Until A=0; if m mod 2 = 0 then WriteLn(m) else WriteLn('Чисел, оканчивающихся двойкой нет.') End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы