Помогите,пожалуйста,написать программу в Паскале через циклы while и repeat. Номер 4.
Помогите,пожалуйста,написать программу в Паскале через циклы while и repeat.
Номер 4.
Ответ(ы) на вопрос:
Гость
1)
const eps=0.5e-6;
var x,xn,a0,a1:real;
begin
readln(x,a0);
xn:=1;
while abs(a0-a1)>=eps do
begin
a0:=a1;
xn:=x*xn;
a1:=sin(1+a0*a0*a0)/xn;
end;
writeln(a1);
end.
2)
const eps=0.5e-6;
var x,xn,a0,a1:real;
begin
readln(x,a0);
xn:=1;
repeat
a0:=a1;
xn:=x*xn;
a1:=sin(1+a0*a0*a0)/xn;
until abs(a0-a1)
Не нашли ответ?
Похожие вопросы