Пожалуйста, напишите программу, которая вводит натуральное число N и определяет является ли число N совершенным. в паскале
Пожалуйста, напишите программу, которая вводит натуральное число N и определяет является ли число N совершенным. в паскале
Ответ(ы) на вопрос:
Совершенное число - натуральное число, равное сумме всех своих собственных делителей (то есть всех положительных делителей, отличных от самого числа).
//Pascal
var
n, s, i: integer;
begin
s := 0;
readln(n);
// Находим делители до n-1, увеличиваем сумму s на i,
// если i - делитель введенного числа
for i := 1 to n - 1 do
if n mod i = 0 then s := s + i;
if s = n then
writeln('cовершенное')
else
writeln('не совершенное');
end.
Не нашли ответ?
Похожие вопросы