Пожалуйста помогите написать программу и составить блоксхему !Определить среди 3 введенных чисел сумму отрицательных и положительных.Если больше сумма положительных,то найти минимум из этих 3 чисел , а иначе найти максимум.
Пожалуйста помогите написать программу и составить блоксхему !
Определить среди 3 введенных чисел сумму отрицательных и положительных.Если больше сумма положительных,то найти минимум из этих 3 чисел , а иначе найти максимум.
Ответ(ы) на вопрос:
uses crt;
var sump,sumn,i:integer;
a:array[1..3] of integer;
begin
for i:=1 to 3 do
begin
read(a[i]);
if a[i]>=0 then
sump:=sump+a[i]
else
sumn:=sumn+a[i];
end;
if sump>=sumn then
writeln(min(min(a[1],a[2]),min(a[2],a[3])))
else
writeln(max(max(a[1],a[2]),max(a[2],a[3])));
end.
М... заморила твоя задача однако
Program asd;
USES crt;
var
A:array [1..5] of integer;
min,max,min2,o,p:real;
i,n:integer;
Procedure max1;
begin
for i:=1 to 5 do
if A[i]>0 then
if minA[i] then
min:=A[i];
Writeln('Min: ',min);
end;
BEGIN
clrscr;
For i:=1 to 5 do
begin
A[i]:=random(9)-5;
Write(' ',A[i]);
end;
Writeln;
//Otrizanie
For i:=1 to 5 do
if A[i]<0 then o:=o+A[i];
Writeln('Summa otrizatelnyx elementov: ',o);
//Polowitelnye
For i:=1 to 5 do
if A[i]>0 then p:=p+A[i];
Writeln('Summa polowitelnyx elementov: ',p);
if p
Не нашли ответ?
Похожие вопросы