Пожалуйста, помогите написать программу в Паскаль. 7 задача

Пожалуйста, помогите написать программу в Паскаль. 7 задача
Гость
Ответ(ы) на вопрос:
Гость
var  k:integer;  t:boolean; begin  read(k);  t := (k div 100 - k div 10 mod 10) = (k div 10 mod 10 - k mod 10);  if t then    writeln('Образуют')  else    writeln('Не образуют') end.
Гость
var   k,i,j,t:integer;   a:array[1..3] of integer; begin   Write('k='); Read(k);   a[1]:=k mod 10;   t:=k div 10;   a[2]:=t div 10;   a[3]:=t mod 10;   for i:=1 to 2 do     for j:=i+1 to 3 do       if a[i]>a[j] then begin t:=a[i]; a[i]:=a[j]; a[j]:=t end;   Write('Цифры числа ',a[1],',',a[2],',',a[3],' ');   if a[3]-a[2]=a[2]-a[1] then Writeln('образуют арифметическую прогрессию')   else Writeln('не образуют арифметическую прогрессию') end.   Пример работы программы k=915 Цифры числа 1,5,9 образуют арифметическую прогрессию
Не нашли ответ?
Ответить на вопрос
Похожие вопросы