Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке. Последовательность завершается числом 0, при считывании которого программа должна закончить свою работу и выве...
Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке. Последовательность завершается числом 0, при считывании которого программа должна закончить свою работу и вывести количество членов последовательности (не считая завершающего числа 0).
Числа, следующие за числом 0, считывать не нужно.
Входные данные
Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).
Выходные данные
Выведите ответ на задачу.
Примеры
входные данные
1
7
9
0
5
выходные данные
3
Ответ(ы) на вопрос:
Гость
Var A,k:integer;
Begin
k:=0;
Read(A);
While A <> 0 do
Begin
Read(A);
k:=k+1;
End;
Write(k)
End.
Не нашли ответ?
Похожие вопросы