Ребята, кто разбирается в программировании, помогите! Составьте программу, вычисляющую, сколько процентов от А+В-С приходится: а) на А б) на Б в) на В
Ребята, кто разбирается в программировании, помогите!
Составьте программу, вычисляющую, сколько процентов от А+В-С приходится: а) на А б) на Б в) на В
Ответ(ы) на вопрос:
program s;
uses crt;
var
a,b,c,d,pa,pb,pc:real;
begin
writeln('Введите А: ');
read(a);
writeln('Введите В: ');
read(b);
writeln('Введите C: ');
read(c);
d:=a+b+c;
pa:=(a/d)*100;
pb:=(b/d)*100;
pc:=(c/d)*100;
writeln('На А приходиться ',pa:2:2,' на В ',pb:2:2,' на С ',pc:2:2); //значание округлены до 2 знаков
end.
Не нашли ответ?
Похожие вопросы