РЕБЯТА ВЫРУЧАЙТЕ, помогите пожалуйста  написать программу в паскале: " Даны два целых числа: D (день) и M (месяц), определяющие правильную дату не високосного года. Вывести значения D и M для даты, предшествующей указанной." И...

 РЕБЯТА ВЫРУЧАЙТЕ, помогите пожалуйста  написать программу в паскале: " Даны два целых числа: D (день) и M (месяц), определяющие правильную дату не високосного года. Вывести значения D и M для даты, предшествующей указанной." ИСПОЛЬЗУЯ КОМАНДУ CASE. 
Гость
Ответ(ы) на вопрос:
Гость
Program a; var D,M: integer; begin  readln (D,M); //DD MM if (D<>1) then Writeln (D-1,' ',M)  else case M of 01 : Writeln('31 12'); 02 : Writeln('31 01'); 03 : Writeln('28 02'); 04 : Writeln('31 03'); 05 : Writeln('30 04'); 06 : Writeln('31 05'); 07 : Writeln('30 06'); 08 : Writeln('31 07'); 09 : Writeln('31 08'); 10 : Writeln('30 09'); 11 : Writeln('31 10'); 12 : Writeln('30 11'); end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы