Решите задачу на паскалеНедавно школьник Петя придумал классную идею для своего стартапа. Идея состоит в том, чтобы написать программу, которая определяет эмоциональный оттенок сообщений пользователей из всем известной социальн...
Решите задачу на паскале
Недавно школьник Петя придумал классную идею для своего стартапа. Идея состоит в том,
чтобы написать программу, которая определяет эмоциональный оттенок сообщений пользователей
из всем известной социальной сети.
Петя считает, что думать над качественным решением задачи нет смысла — ведь приложение
нужно как можно скорее выбросить на рынок, пока этого не сделали конкуренты. Поэтому в первой
версии Петя собирается использовать следующий алгоритм:
• Сначала в сообщении нужно посчитать количество символов «)», «(», «!» и «.».
• Если в сообщении больше всего символов «)» — значит автору сообщения весело, и программа
должна вывести «Funny».
• Если в сообщении больше всего символов «(» — значит автору сообщения грустно, и програм-
ма должна вывести «Sad».
• Если в сообщении больше всего символов «!» — значит автор сообщения раздражен, и про-
грамма должна вывести «Angry».
• Если в сообщении больше всего символов «.» — значит перед нами какое-то глубокомысленное
сообщение с большим числом многоточий, и программа должна вывести «Deep».
• Если каких-либо наиболее число встречающихся символов (из перечисленных выше) поровну
— то тогда эмоция сообщения не понятна и программа должны вывести «Unclear».
Ответ(ы) на вопрос:
program znanija.com;
var
s: string;
a:array[1..4] of integer;
i:integer;
begin
read(s);
for i:=1 to 4 do a[i]:=0;
for i:=0 to length(s) do
begin
if s[i]=')' then inc(a[1]);
if s[i]='(' then inc(a[2]);
if s[i]='!' then inc(a[3]);
if s[i]='.' then inc(a[4]);
end;
if(a[1]>a[2])and(a[1]>a[3])and(a[1]>a[4]) then write('Funny')else
if(a[2]>a[1])and(a[2]>a[3])and(a[2]>a[4]) then write('Sad') else
if(a[3]>a[2])and(a[3]>a[1])and(a[3]>a[4]) then write('Angry') else
if(a[4]>a[2])and(a[4]>a[3])and(a[4]>a[1]) then write('Deep') else
write('Unclear');
end.
Не нашли ответ?
Похожие вопросы