С клавиатуры вводят слово и символ.составить программу,которая: а)проверяет есть ли в этом слове заданный символ б)определяет позицию заданного символа в)подсчитывает количество вхождений заданного символа.
С клавиатуры вводят слово и символ.составить программу,которая: а)проверяет есть ли в этом слове заданный символ б)определяет позицию заданного символа в)подсчитывает количество вхождений заданного символа.
Ответ(ы) на вопрос:
var s : string; symb : char; i : longint;
begin
readln(s);
readln(symb);
if pos(symb,s)=0 then writeln('В этом слове нет этого символа')
else begin
i:=0;
while pos(symb,s)<>0 do begin
write(pos(symb,s)+i,' ');
i:=i+1;
Delete(s,pos(symb,s),1);
end;
end;
writeln;
writeln(i);
end.
Не нашли ответ?
Похожие вопросы