С клавиатуры вводят слово.Составить программу ,которая: а)определяет количество символов в нём б)проверяет,не совпадают ли первая и последняя буквы слова в)выводт на экран первый,второй и последний символы г)определяет,чётно ил...

С клавиатуры вводят слово.Составить программу ,которая: а)определяет количество символов в нём б)проверяет,не совпадают ли первая и последняя буквы слова в)выводт на экран первый,второй и последний символы г)определяет,чётно или нечётно количество символов в нём 
Гость
Ответ(ы) на вопрос:
Гость
uses crt; var s: string; begin writeln('Напишите слово'); readln(s); writeln(length(s) ,' символов'); writeln(s[1] ,' первый символ ', s[2] ,' второй символ ', s[length(s)] ,' последний символ'); if (s[length(s)] = s[1]) then begin writeln('совпадают'); end else writeln('не совпадают'); if (length(s) mod 2 = 0) then begin writeln('четное кол-во'); end else writeln('не четное'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы