С++ Написать программу в которой генерируются 10 случайныx чисел в диапазоне от -5 до 30. Посчитать среднее арифметическое чисел которые больше 10. (Использовать цикл for)
С++
Написать программу в которой генерируются 10 случайныx чисел в диапазоне от -5 до 30. Посчитать среднее арифметическое чисел которые больше 10.
(Использовать цикл for)
Ответ(ы) на вопрос:
Гость
#include
#include
#include
using namespace std;
int main() {
int sum = 0;
int cnt = 0;
srand(time(0));
cout << "Numbers: ";
for (int i = 0; i < 10; i++) {
int a = rand() % 36 - 5;
cout << a << " ";
if (a > 10) {
cnt++;
sum += a;
}
}
cout << "\nAverage value = " << (double) sum / cnt;
return 0;
}
Гость
#include
#include
#include
using namespace std;
int main()
{
srand(time(NULL));
int a[10];
int k,sum=0;
cout<<"исходные числа:"<10)
{
k=k+1;
sum=sum+a[i];
}
}
cout<<""<
Не нашли ответ?
Похожие вопросы