С ПОМОЩЬЮ ПАСКАЛЯ                  Дана информация о температуре воздуха за январь. Написать программу, которая:а)Определит сколько раз температура опускалась ниже 0 градусовб)Определит среднюю температуру за январь

С ПОМОЩЬЮ ПАСКАЛЯ                  Дана информация о температуре воздуха за январь. Написать программу, которая: а)Определит сколько раз температура опускалась ниже 0 градусов б)Определит среднюю температуру за январь
Гость
Ответ(ы) на вопрос:
Гость
var    st:real;    i,n:integer;    t:array[1..31]of integer; begin writeln('Температура в январе:'); for i:=1 to 31 do   begin  t[i]:=random(-10,5);   write(t[i],' ');   st:=st+t[i];   if t[i]<0 then n:=n+1   end; st:=st/31; writeln; writeln('Число дней с отр.температурой: ',n); writeln('Средняя температура: ',st:1:1) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы