Серёжа мечтает о том, что бы каждый второй символ был #. Он пытался написать программу, которая вводила строку, а потом выводила вместе каждого второго символа "#", но у него не получилось этого сделать. Помогите ему осуществит...

Серёжа мечтает о том, что бы каждый второй символ был #. Он пытался написать программу, которая вводила строку, а потом выводила вместе каждого второго символа "#", но у него не получилось этого сделать. Помогите ему осуществить свою мечту. ))) Формат ввода: вводится строка Формат вывода: выводится строка, где каждый второй символ заменён нам "#" Пример ввода: Milye druz'ya Пример вывода: M#l#e#d#u#'#a
Гость
Ответ(ы) на вопрос:
Гость
var   s:string;   i:byte; begin   Write('Введи строку: '); Readln(s);   i:=2;   while i<=length(s) do begin s[i]:='#'; i:=i+2 end;   Writeln(s) end. Тестовое решение: Введи строку: Milye druz'ya M#l#e#d#u#'#a
Не нашли ответ?
Ответить на вопрос
Похожие вопросы