Си ++!!. Написать программу нахождения среднего арифметического всех целых чисел от a до b (значения a и b вводятся с клавиатуры; a меньше b) 

Си ++!!. Написать программу нахождения среднего арифметического всех целых чисел от a до b (значения a и b вводятся с клавиатуры; a
Гость
Ответ(ы) на вопрос:
Гость
#include using namespace std; int main() { setlocale(LC_ALL, "Russian"); char key; int i; int a[255]; float arifm=0,sum=0,b=0; cout << "Введите числа от а до б через пробел! (Условие: a < b)"<> a[i]; if(i >= 1 && a[i] < a[i-1]){ break; } b++; } cout << "Получили числа: "; for (i=0;i < b; i++){ cout << " " << a[i]; sum += a[i]; } cout << endl<< "Сумма чисел = " << sum << endl; arifm = sum / (b); cout << "Среднее арифметическое = " << arifm << endl; system ("pause"); }   Только не дописал выход из цыкла.. сейчас он при нарушение условия а < б Если надо думаю справитесь с do while 
Не нашли ответ?
Ответить на вопрос
Похожие вопросы