Составить блок схему и написать программу, которая находит сумму нечетных и количество четных делителей натурального числа.(31954)
Составить блок схему и написать
программу, которая находит сумму нечетных и количество четных делителей натурального числа.(31954)
Ответ(ы) на вопрос:
Гость
var n,i,k,s:integer;
begin
read (n);
k:=0;
s:=0;
for i:=1 to n do
begin
if (n mod i = 0) then
begin
if (i mod 2 = 0)then
begin
k:=k+1;
end else
begin
s:=s+i;
end;
end;
end;
writeln ('Кол-во чётных - ',k);
writeln ('Сумма нечётных - ',s);
end.
Не нашли ответ?
Похожие вопросы