Составить программу , которая уменьшает первое число в два раза а второе увеличивает на 1 если первое больше 2
Составить программу , которая уменьшает первое число в два раза а второе увеличивает на 1 если первое больше 2
Ответ(ы) на вопрос:
Var
A,d:integer
Begin
Read(a);
Read(d)
Write(a*2);
Begin
If (a>d) then
Write(d+1)
End;
End.
1) файл паскаля приложен.
2) код на c#
static void Main(string[] args) { int a, b; a = Convert.ToInt32(Console.ReadLine()); b = Convert.ToInt32(Console.ReadLine()); if (a > 2) { Console.WriteLine(a / 2); Console.WriteLine(b - 1); } }
3) Код на vb
dim a as integer = 0
dim b as integer = 0
a = cint(console.readline())
b = cint(console.readline())
if a > 2 then
console.writeline( a / 2)
console.writeline(b - 1)
end if
Не нашли ответ?
Похожие вопросы