Составить программу, которая упорядочивает элементы четных строк по возрастанию,а нечетных по убыванию.Матрица размером 8х8.Полученную матрицу напечатать.

Составить программу, которая упорядочивает элементы четных строк по возрастанию,а нечетных по убыванию.Матрица размером 8х8.Полученную матрицу напечатать.
Гость
Ответ(ы) на вопрос:
Гость
var    i,j,k,p:integer;    a:array[1..8,1..8]of integer; begin writeln('Исходный массив:'); for i:=1 to 8 do begin  for j:=1 to 8 do     begin        a[i,j]:=random(20);     write(a[i,j]:3)     end;     writeln end; for i:= 1 to 8 do      for j:= 1 to 8 do      for k:= 1 to 8 do         begin         if i mod 2=0 then            begin            if (a[i,j] a[i,k] then                  begin                  p:=a[i,j];                  a[i,j] := a[i,k];                  a[i,k] := p                  end        end; writeln('Преобразованный массив:'); for i:=1 to 8 do    begin    for j:=1 to 8 do       write(a[i,j]:3);    writeln    end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы