Составить программу, которая заполняет массив из 20 элементов с помощью генератора случайных чисел. Требуется вывести элементы массива на экран компьютера в одну строку, а затем определить сумму элементов массива и среднее ариф...

Составить программу, которая заполняет массив из 20 элементов с помощью генератора случайных чисел. Требуется вывести элементы массива на экран компьютера в одну строку, а затем определить сумму элементов массива и среднее арифметическое массива.
Гость
Ответ(ы) на вопрос:
Гость
Program n1; var a: array[1..20] of integer; i,sum: integer; begin randomize; write('исходный массив: '); sum:=0; for i:=1 to 20 do begin a[i]:=random(21); write(a[i],' '); sum:=sum+a[i]; end; writeln; writeln('сумма: ',sum); writeln('срзнач: ',sum/20); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы