Составить программу, которая запрашивает координаты двух точек, а выводит длину отрезка, концами которого эти точки являются, и координаты середины этого отрезка. (Блок систему и на языке паскаль)

Составить программу, которая запрашивает координаты двух точек, а выводит длину отрезка, концами которого эти точки являются, и координаты середины этого отрезка. (Блок систему и на языке паскаль)
Гость
Ответ(ы) на вопрос:
Гость
Program Programma; Uses crt; var xA,xB,yA,yB,D: real; Begin clrscr; write('Введите координаты точки A через пробел: '); readln(xA,yA); write('Введите координаты точки B через пробел: '); readln(xB,yB); d:=sqrt(sqr(xA-xB)+sqr(yA-yB)); writeln; write('Длина отрезака AB = ',d:0:3) End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы