Составить программу на паскале находящюю самое длинное слово в строке начинающееся на букву А , и выводящуюю количество букв в нём?????
Составить программу на паскале находящюю самое длинное слово в строке начинающееся на букву А , и выводящуюю количество букв в нём?????
Ответ(ы) на вопрос:
var s:string;
i,n,max:byte; begin
n:=0;i:=1;max:=0;
write('Введите s -> ');readln(s); while i<=length(s) do begin
if (i=1) or (s[i]=' ') then begin
if i <> 1 then inc(i);
if (i<=length(s))and((s[i]='a') or (s[i]='A')) then while i<=length(s) do
if s[i]<>' ' then begin
inc(n);
inc(i);
end else break;
end;
inc(i); if max