Составить программу нахождения суммы значений функции x^2,если x меньше 0 y= x^3, еслиx больше =0 на отрезке [-3:3] с шагом 1...Помогите пожалуйста
Составить программу нахождения суммы значений функции
x^2,если x<0
y= x^3, еслиx>=0
на отрезке [-3:3] с шагом 1...Помогите пожалуйста
Ответ(ы) на вопрос:
Гость
var x,y,s,s1:integer;
begin
s:=0;s1:=0;
for x:=-3 to 3 do begin
if x<0 then s:=s+sqr(x);
if x>=0 then s1:=s1+x*sqr(x);
end;
writeln('s=',s);
writeln('s1=',s1);
end.
Не нашли ответ?
Похожие вопросы