(Составить программу по Pascal)Дано двузначное число. Определить, кратна ли сумма его цифр 6.Подсказка: Нужно отделить от числа единицы и десятки. Чтобы узнать, сколько десятков в числе, нужно поделить число нацело на 10. Резул...
(Составить программу по Pascal)
Дано двузначное число.
Определить, кратна ли сумма его цифр 6.
Подсказка:
Нужно отделить от числа единицы и десятки. Чтобы узнать, сколько десятков в
числе, нужно поделить число нацело на 10. Результат присвоить какой-нибудь
переменной. Затем исходное число поделить с помощью команды MOD на 10 и
результат записать в другую переменную.
Ответ(ы) на вопрос:
program zad6;
var n, d, e, s: integer;
begin
readln (n);
d:=n div 10;
e:= n mod 10;
s:=d+e;
if s mod 6=0 then writeln (' сумма цифр числа кратна 6') else writeln (' сумма цифр числа не кратна 6');
end.
Не нашли ответ?
Похожие вопросы