Составить программу, решающую следующую задачу: Вы покупаете товар, и у Вас имеются монеты номиналом 1, 2, 5, 10 рублей. Наберите необходимую сумму товара в N рублей так, чтобы она состояла из минимального количества монет. язы...
Составить программу, решающую следующую задачу: Вы покупаете товар, и у Вас имеются монеты номиналом 1, 2, 5, 10 рублей. Наберите необходимую сумму товара в N рублей так, чтобы она состояла из минимального количества монет. язык паскаль
Ответ(ы) на вопрос:
Гость
program noname;
var a,b,c,d,e;
begin
readln(a);
b:=a div 10;
a:=a-b;
c:=a div 5;
a:=a-c;
d:=a div 2;
a:=a-d;
e:=a;
writeln('Десяток:',b);
writeln('Пятёрок:',c);
writeln('Двоек:',d);
writeln('Единиц:',e);
writeln('Всего монет:'(b+c+d+e));
end.
Не нашли ответ?
Похожие вопросы