Составить программу, содержащую операторы ввода, вывода, присваивания. 9)Найти произведение всех цифр заданного четырехзначного числа.

Составить программу, содержащую операторы ввода, вывода, присваивания. 9)Найти произведение всех цифр заданного четырехзначного числа.
Гость
Ответ(ы) на вопрос:
Гость
program znanija; var a, res:integer; begin res := 1; write('Введите число: '); readln(a); while a>1 do begin res := res * (a mod 10); a := a div 10; end; writeln('Произведение всех цифр = ', res); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы