Составить программу в Паскаль: Ученик в первый день выучил Х английских слов. В каждый следующий день он выучивал на К слов больше, чем в предыдущий. Сколько английских слов он будет знать в N-й день занятий?

Составить программу в Паскаль: Ученик в первый день выучил Х английских слов. В каждый следующий день он выучивал на К слов больше, чем в предыдущий. Сколько английских слов он будет знать в N-й день занятий?
Гость
Ответ(ы) на вопрос:
Гость
На первую часть задачи можно ответить устно без калькулятора. Складываем подряд цифры за десять дней начиная с 5 в первый день и завершая 23 в десятый. Итого: 5+7+9+11+13+15+17+19+21+23=140. 140 слов он будет знать на 10-ый день. 250 слов получится на 14-ый день. Второй способ подсчета - блок-схема: var i,p,s:integer; begin i:=1; p:=5; s:=p; repeat i:=i+1; p:=p+2; s:=s+p until s>=250; writeln(i) end. Расшифровка: i - дни. Они увеличиваются на один. p - количество слов, изначально пять, но потом по две добавляется. Сумма больше или равно 250. Подсчитать количество дней. В ответе также будет 14.
Гость
var x,k,n,s,i:integer; begin writeln('x, k, n:'); readln(x,k,n); s:=x; for i:=2 to n do  begin  x:=x+k;  s:=s+x;  end; writeln('s = ',s); end. Пример: x, k, n: 10 2 5 s = 70
Не нашли ответ?
Ответить на вопрос
Похожие вопросы