Составить программу в Паскаль:Дано число меньше 16 определить - сколько единичных битов содержит двоичная запись этого числа.
Составить программу в Паскаль:Дано число меньше 16 определить - сколько единичных битов содержит двоичная запись этого числа.
Ответ(ы) на вопрос:
var b,a,c,kol:integer;
begin
writeln('введите число в десятичной системе счисления');
readln(a);
kol:=0;
while(a>=2) do begin
c:=a div 2;
b:=2*c;
b:=a-b;
writeln(b);
a:=c;
if a<2 then
writeln(a);
if a > 0 then
kol:=kol+1;
end;
writeln('количество 'kol);
end.
Не нашли ответ?
Похожие вопросы