Составить программу в паскале, которая определит, поместится ли квадрат со стороной А в круг радиуса R, или круг в квадрат.
Составить программу в паскале, которая определит, поместится ли квадрат со стороной А в круг радиуса R, или круг в квадрат.
Ответ(ы) на вопрос:
var a, r: real;
begin
write('a = '); read(a);
write('r = '); read(r);
if r >= a/sqrt(2) then writeln('Квадрат поместится в круг')
else if r <= a/2 then writeln('Круг поместится в квадрат')
else writeln('Круг и квадрат не поместятся друг в друга')
end.
Пояснение:
Радиус описанной около квадрата окружности равен половине диагонали квадрата. Диагональ квадрата по теореме Пифагора = √(a² + a²) = a√2, соответственно радиус = a√2/2 = a/√2. Если радиус данной окружности, больше либо равен a/√2, тогда квадрат помещается в круг.
Радиус вписанной в квадрат окружности равен половине его стороны, т.е a/2. Если радиус данной окружности меньше либо равен, чем a/2, тогда круг вмещается в квадрат.
Не нашли ответ?
Похожие вопросы