Составить программу в паскале. Найти количество положительных элементов массива Х(3,3), заполненного с клавиатуры.
Составить программу в паскале. Найти количество положительных элементов массива Х(3,3), заполненного с клавиатуры.
Ответ(ы) на вопрос:
program foo;
var
b : array[1..3] of array[1..3] of integer;
c : integer;
i, j : byte;
begin
writeln('Заполните массив:');
for i := 1 to 3 do begin
writeln('Строка ', i);
for j := 1 to 3 do
readln(b[i][j]);
end;
c := 0;
for i:=1 to 3 do begin
for j:=1 to 3 do begin
write(b[i][j]:5, ' ');
if b[i][j] > 0 then inc(c, 1);
end;
writeln;
end;
writeln('Найдено ', c, ' положительных элементов');
end.
Не нашли ответ?
Похожие вопросы