Составить программу в паскале с использованием циклических операторов: Среди всех чисел,меньших к ( к меньше =999) указать те, сумма цифр которых равна даномучислу n

Составить программу в паскале с использованием циклических операторов: Среди всех чисел,меньших к ( к<=999) указать те, сумма цифр которых равна даномучислу n
Гость
Ответ(ы) на вопрос:
Гость
function sum(i, n: integer): boolean; var   a, b: integer; begin   a := i;   repeat     b := b + a mod 10;     a := a div 10;   until (a = 0);   sum := (b = n); end; var   n, i, k: integer; begin   readln(n, k);   for i := 1 to k do     if sum(i, n) then       writeln(i); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы