Составить программу в Паскале. Тестируется группа из n человек. Каждый вводит 1,если изучает английский,2-немецкий,3-французский,0-никакой. Определить сколько человек в каждой языковой группе. С операторами for и case.
Составить программу в Паскале.
Тестируется группа из n человек. Каждый вводит 1,если изучает английский,2-немецкий,3-французский,0-никакой. Определить сколько человек в каждой языковой группе.
С операторами for и case.
Ответ(ы) на вопрос:
Гость
var
n,i,otv,l,m,h,k: integer;
begin
writeln ('сколько человек в группе');
read (n);
for i:=1 to n do
begin
writeln ('какой язык ты изучаешь: 1-англ,2-нем,3-франц,0-никакой');
read (otv);
case otv of
0: l:=l+1;
1: h:=h+1;
2: k:=k+1;
3: m:=m+1;
end;
end;
writeln ('английский язык изучает',h,'человек');
writeln ('немецкий язык изучает',k,'человек');
writeln ('французский язык изучает',m,'человек');
writeln (l,'человек не изучает никакой язык');
end.
Не нашли ответ?
Похожие вопросы