Составить программу в с++ Дано натуральное число: 1) найти кол-во четных цифр этого числа 2) верно ли, что в Данном числе встречается A и B (числа A и B вводится с клавиатуры)
Составить программу в с++
Дано натуральное число:
1) найти кол-во четных цифр этого числа
2) верно ли, что в Данном числе встречается A и B (числа A и B вводится с клавиатуры)
Ответ(ы) на вопрос:
Гость
1)
#include
#include
using namespace std;
int main() {
int a, k = 0;
cin >> a;
for(int b = abs(a);b > 0; b/=10)
if(b%10%2 == 0) k++;
cout << k << endl;
}
2)
#include
#include
using namespace std;
int main() {
int n, a, b;
bool flagA = false, flagB = false;
cin >> n >> a >> b;
for(int d = abs(n);d > 0; d/=10) {
if(d%10 == a) flagA = true;
else if(d%10 == b) flagB = true;
}
cout << ((flagA && flagB) ? "true" : "false") << endl;
}
Не нашли ответ?
Похожие вопросы