Составить программу возведения натурального числа в квадрат, используя следующую закономерность: I2 =1 2 2=1+3 З2 =1 + 3 + 5 42=1+3+5+7 п2 = 1 + 3 + 5 + 7 + 9 + . . . + 2 п - 1 Программа Pascal

Составить программу возведения натурального числа в квадрат, используя следующую закономерность: I2 =1 2 2=1+3 З2 =1 + 3 + 5 42=1+3+5+7 п2 = 1 + 3 + 5 + 7 + 9 + . . . + 2 п - 1 Программа Pascal
Гость
Ответ(ы) на вопрос:
Гость
Всё до безобразия просто:  var n:integer; nn:real; begin   write('Введи число: ');   readln(n);   for var i:=1 to n do nn:=nn+(2*i-1);   writeln(n,'^2=',nn); end.  
Гость
Function MySQR(n : Integer) : Integer; Begin   If n>1 then MySQR:=n+MySQR(n-2) else MySQR:=1; end; Var a : Integer; Begin   Readln(a);   Writeln(MySQR(a*2-1)); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы