Составить программу вычисления значений функции F(x) на отрезке [a ; b] с шагом h. Результат представить в виде таблицы. Первый столбец которой - значения аргументов, второй - соответствующие значения функции: F(x) = xcos(1/x)+2.
Составить программу вычисления значений функции F(x) на отрезке [a ; b] с шагом h. Результат представить в виде таблицы. Первый столбец которой - значения аргументов, второй - соответствующие значения функции: F(x) = xcos(1/x)+2.
Ответ(ы) на вопрос:
Гость
var a,b,h,x,f:real; n,i:integer;
begin
write('a=');readln(a);
write('b=');readln(b);
h:=0.2;
x:=a-h;
n:=round((b-a)/h)+1;
writeln(' № x f(x)');
for i:=1 to n do
begin
x:=x+h;
write(i:2,' ',x:4:1,' ');
if abs(x)>1e-16
then writeln(x*cos(1/x)+2:8:4)
else writeln(' функция не определена');
end;
end.
Пример:
a=-1
b=1
№ x f(x)
1 -1.0 1.4597
2 -0.8 1.7477
3 -0.6 2.0574
4 -0.4 2.3205
5 -0.2 1.9433
6 0.0 функция не определена
7 0.2 2.0567
8 0.4 1.6795
9 0.6 1.9426
10 0.8 2.2523
11 1.0 2.5403
Не нашли ответ?
Похожие вопросы