Составить программу, вычисляющую площадь геометрической фигуры. Тип фигуры определяется символом (с): О – окружность, T – равнобедренный прямоугольный треугольник и K – квадрат. Целое число, вводимое вслед за символом определяе...

Составить программу, вычисляющую площадь геометрической фигуры. Тип фигуры определяется символом (с): О – окружность, T – равнобедренный прямоугольный треугольник и K – квадрат. Целое число, вводимое вслед за символом определяет соответствующий элемент для вычисления площади (для окружности это радиус, для треугольника – длина катета, для квадрата – длина стороны).
Гость
Ответ(ы) на вопрос:
Гость
var S, X, a, b, R: Real; C: String; Begin WriteLn('Chto budem vichislat'); ReadLn(C); if C = 'O' then begin WriteLn('Radius'); ReadLn(R); S:= Pi*sqr(R); end; if C:= 'T' then begin WriteLn('Vvedite 1 katet); ReadLn(a); WriteLn('Vvedite 2 katet); ReadLn(b); S:= 1/2 * a * b; end; if C:= 'K' then begin WriteLn('Vvedite 1 katet); ReadLn(a); S:= sqr(a); end; WriteLn('Ploshad = '); ReadLn(S); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы