Составить программу вывода N случайных целых чисел диапазона от 0 до 50. определить сколько среди них четных, а сколько нечетных
Составить программу вывода N случайных целых чисел диапазона от 0 до 50. определить сколько среди них четных, а сколько нечетных
Ответ(ы) на вопрос:
program gt;
var a,l,k,n,i:integer;
begin
read(N);
randomize;
k:=0;
l:=0;
for i:=1 to n do
begin
a:=random(50);
if(a mod 2=0)then k:=k+1 else l:=l+1;
write(a,' ');
end;
writeln;
writeln('четные=',k);
writeln('не четные=',l);
end.
Не нашли ответ?
Похожие вопросы