Составить программу:1. Задано пятизначное число. Выделить цифры, стоящие в разряде единиц и разряде тысяч. Вывести их в порядке убывания 2. Задано четырехзначное число. Удалить из записи числа последнюю цифру. Определить, будет...
Составить программу:
1. Задано пятизначное число. Выделить цифры, стоящие в разряде единиц и разряде тысяч. Вывести их в порядке убывания
2. Задано четырехзначное число. Удалить из записи числа последнюю цифру. Определить, будет ли оставшееся число кратно 11
Ответ(ы) на вопрос:
1.
uses crt;
var x:integer;
begin
read(x);
if inttostr(x)[1]>inttostr(x)[5] then
writeln(inttostr(x)[1],' ',inttostr(x)[5])
else
writeln(inttostr(x)[5],' ',inttostr(x)[1]);
end.
2.
uses crt;
var x:integer;
begin
read(x);
if (x div 10) mod 11=0 then
writeln('Yes')
else
writeln('No');
end.
Не нашли ответ?
Похожие вопросы