Составьте программу для вычисления значения функции y= -3, если x≤0 x, если 0 меньше х≤1 х², в остальных случаях
Составьте программу для вычисления значения функции
y=
-3, если x≤0
x, если 0<х≤1
х², в остальных случаях
Ответ(ы) на вопрос:
[latex]y=\begin {cases} -3, \quad x \leq 0 \\ x, \quad 0\ \textless \ x \leq 1 \\ x^2, \quad x \ \textgreater \ 1 \end {cases}[/latex]
var
x,y:real;
begin
Write('Введите число: '); Read(x);
if x<=0 then y:=-3
else
if x<=1 then y:=x else y:=sqr(x);
Writeln('y=',y)
end.
Не нашли ответ?
Похожие вопросы