Составьте программу которая формирует массив из 20 целых чисел и вычисляет средние арифметическое нечетный чисел

Составьте программу которая формирует массив из 20 целых чисел и вычисляет средние арифметическое нечетный чисел
Гость
Ответ(ы) на вопрос:
Гость
var mas:array[1..20] of integer;     i, sum:integer; begin      for i:=1 to 20 do      begin           mas[i]:=random(99);                     write(mas[i], ' ');      end;           writeln;           i:=1;      while(i < 20) do      begin           sum:=sum+mas[i];           i:=i+2;      end;           writeln('Среднее арифметическое нечётных элементов массива ', sum/10); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы