Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от -40 до 40 и увеличивает в 2 раза числа , кратные 5, а остальные уменьшает на 2.

Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от -40 до 40 и увеличивает в 2 раза числа , кратные 5, а остальные уменьшает на 2.
Гость
Ответ(ы) на вопрос:
Гость
var     a: array[1..100] of integer;     i, n: integer; begin     {ввод массива}     n := 15;          writeln('Данные массива:');     for i := 1 to n do     begin         a[i] := random(40 + 40) - 40;         write(a[i], ' ');     end;     writeln();          {изменение элементов}     for i := 1 to n do     begin         if a[i] mod 5 = 0 then             a[i] := 2 * a[i]         else a[i] := a[i] - 2;         write(a[i], ' ');     end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы