Составьте программу, которая по введенному вами K - числу грибов печатает фразу меньше Мы нашли в лесу K грибов больше , причем согласовывает окончание слова меньше гриб больше с числом K. Количество грибов может быть любым ...

Составьте программу, которая по введенному вами K - числу грибов печатает фразу <Мы нашли в лесу K грибов>, причем согласовывает окончание слова <гриб> с числом K. Количество грибов может быть любым целым числом: 1, 3, 34, 127 и т.д. Окончание фразы определяется значением последней цифры.
Гость
Ответ(ы) на вопрос:
Гость
var g,i:integer; begin  read(g); if (g=1) or ((g>20) and (g mod 10=1)) then begin writeln('Мы нашли в лесу ',g,' гриб'); i:=1; end; if ((g mod 10>1) and (g mod 10<5)) or ((g>21) and (g mod 10>1) and (g mod 10<5)) then begin writeln('Мы нашли в лесу ',g,' гриба'); i:=1; end; if i=0 then writeln('Мы нашли в лесу ',g,' грибов'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы